SPIP Blog

Du logiciel libre et de la tendresse

Accueil > Release > Chouette : SPIP 3.2 alpha !

Chouette : SPIP 3.2 alpha !

vendredi 24 mars 2017, par La team

Nous sommes heureux de vous présenter la version alpha de SPIP 3.2

Testez dès maintenant cette nouvelle version disponible au téléchargement :
https://files.spip.net/spip/archives/SPIP-vtrois.2.0-alpha-1.zip

Attention : c’est une version alpha, elle peut encore contenir des bugs.
Ne faites pas de mise à jour vers cette version depuis un site en production sans savoir ce que vous faites.

SPIP 3.2 alpha, les nouveautés

Un SPIP plus moderne :

  • Compatibilité PHP 7.1
  • La dernière version de jQuery (3.2.1) et les autres bibliothèques javascript mises à jour

Un SPIP plus ergonomique :

Un SPIP plus stable :

  • Correction de bugs
  • Évolution de code

Le détail des évolutions pour migrer vers SPIP 3.2 :
https://contrib.spip.net/SPIP-3-2-alpha-changelog

Avec la mise à jour des bibliothèques Javascript, certains plugins nécessiteront peut être des modifications.

Merci à tous testeurs, testeuses, curieux et autres aventuriers, de nous faire leurs retours sur cette version :

Messages

  • Je ne vais pas tester ce coup-ci. Mais c’est une très bonne nouvelle.

  • Merci et merci encore pour votre engagement dans ce bel outil !
     ;)

  • premiier essai d’installation chez OVH
    juste après /écrire

    écran d’alerte

    Warning : Wrong parameter count for clearstatcache() in
    /home/cieavril/www/spip32a/ecrire/inc/flock.php on line 464

    Warning : Wrong parameter count for clearstatcache() in
    /home/cieavril/www/spip32a/ecrire/inc/flock.php on line 464

    Warning : Wrong parameter count for clearstatcache() in
    /home/cieavril/www/spip32a/ecrire/inc/flock.php on line 464

    Warning : Wrong parameter count for clearstatcache() in
    /home/cieavril/www/spip32a/ecrire/inc/flock.php on line 464
    HTTP 302
    Si votre navigateur n’est pas redirigé, cliquez ici pour continuer.

    Clic dans le lien de la dernière ligne (si votre ordinateur ...)
    donne accès au premier écarn habituel d’installation de spip

    Installation du système de publication...

    SPIP 3.2.0-alpha-1 [23482] est un logiciel libre distribué sous licence
    GPL.
    + écran de sécurité 1.3.0

    Cmic dans suivante

    écran d’alerte

    Installation du système de publication...
    ATTENTION !

    L’installation va probablement échouer, ou aboutir à un site non
    fonctionnel...

    PHP version 5.2.17 insuffisant (minimum = 5.3.0)

    VOILA

    je n’ai pas été plus loin

  • Bon j’ai été plus loin
    en vérifiant ma version OVH de PHP.... 5.2.6 (et oui !)
    PUIS
    en imposant la version de PHP à 5.6 avec mon fichier .ovhconfig à la racine
    ET

    TOUT a bien fonctionné jusqu’à la complète installation de Spip 3.2 Alpha chez OVH avec un PHP en 5.6
    en continuant
    dossier Plugins Dossier Auto

    PUIS
    essai de mise en place des plugins.. et là .. DECONVENUE

    quasiment moins de 20 plugins possibles... donc quasiment aucun squelette

    je continue et vous tiens au courant

  • Super, bravo ! :)

    Au fait, pourquoi pas aussi du glisser/déposer pour trier les articles du coup ? ça éviterait de devoir jouer avec le numéro de position ^^

  • @Boudry Michel : c’est une alpha… donc normal que peux de plugin dispo. Il faut que les dev de plugins tests et voient si cela marche. Mais tu peux faire toi aussi les tests sur les plugins qui t’intéresse.

    Il faut modifier les bornes de compatibilité dans paquet.xml/plugin.xml, ce qui te permet d’activer le plugin, pour ensuite tester s’il est effectivement compatible… et faire un retour auprès des dev en conséquences.

  • Et donc j’ai modifié le paquet.xml du plugins Sarkaspip 3.4.6....en ajoutant un ;3.2.*
    et j’ai essayé de faire fonctionner
    Sarkaspip 3.4.6
    avec
    Spip 3.2 alpha

    j’ai déposé le Sarkaspip3.4.6 à paquet.xml modifié en ftp dans plugins/auto du site
    ... car
    Sarkaspip n’est PAS visible dans les dépôts ...avec Spip 3.2alpha... les dépôts ont encore une limite à 3.1.*... donc c’est « normal »

    Dans gestion des plugins... Sarkaspip modifié ( ;3.2*)... est perçu comme non installable et non compatible
    mais cela peut aussi venir des installations des plugins nécessaires à Sarkaspip
    je continue

  • a oui, effectivement si SarkaSpip demande des plugins qui ne sont pas testés 3.2, cela ne peux s’installer. C’est justement le principe d’une alpha : faire des tests.

  • Bonjour,
    je tente depuis deux jours de refaire un serveur web sur une version Ubuntu Server 16.04 avec spip 3.1.4. Pas de difficultés particulières. Ubuntu à jour. Lorsque je veux executer l’installation de spip, tout se passe normalement jusqu’à ce que je modifie les droits des 4 repertoires IMG,.... A ce stade je me retrouve avec une page blanche et ne m’en sors pas. Nombreuses tentatives et ré-installations plus tard, meme état des lieux. J’apprécierais énormément une solution si d’aventure quelqu’un la possède. Merci d’avance et félicitations pour votre implication dans le développement de SPIP.

  • @Georges, un chown -R www-data:www-data IMG devrait faire l’affaire, mais le plus simple serait que tu passes en causer sur IRC afin qu’on t’aide à débloquer la situation : http://irc.spip.net/

  • Bonjour à tous

    J’ai noté que le plugin crayon était noté comme compatible avec 3.*.* et il semble effectivement fonctionner normalement.
    Les plugins enluminures_typographiques_v3, facteur, formidable, menus, nospam, pages, saisies, socialtags, spip-bonux-3, vérifier, yawl, cfg couteau_suisse et a2a_v2 semblent fonctionner correctement. Les mails partent (je ne sais pas si nospam bloque les spammers, mais je sais qu’il ne me bloque pas si j’envoie un mail). A2A affiche correctement les liens, et les fonctionnalisés que j’utilise du couteau suisse fonctionnent correctement.

    Par contre Album ouvre les images en changeant de page dans la même fen^tre et plus en pop-in.

    J’ai fait les tests sur un clone d’un site en prod ce qui m’a permis de comparer. Tous les plugins sont dans leur dernière version.

    J’ai quelques petites différences d’affichage (il faudrait que je regarde les css de plus près) et j’ai donc gardé les squelettes que j’ai fait (et non le squelette-dist).

    En vérité je vois peux de différence avec la dernière version stable, mais je ne suis resté dessus qu’une petite heure.

    Ah oui. quand je suis dans l’admin dans une motif d’article et que je clique sur modifier une image qui est dans le portfolio le potin s’ouvre, le loader tourne tourne tourne mais rien ne se passe. J’ai essayé avec des images différentes et plutôt légères.

    En tout cas, merci à tous pour ce CMS, pour ce travail et sa qualité.
    Amicalement
    Denis

  • Au fait, pourquoi pas aussi du glisser/déposer pour trier les articles du coup ? ça éviterait de devoir jouer avec le numéro de position ^^
    Je plussoie et je dirais même pourquoi ne pas étendre ce principe à tout objet listable !

  • Bonjour,

    Je teste SPIP 3.2 en local, pas évident de trouver un bon squelette et les thèmes de Shizuka via le plugins Zen-Garden ne fonctionnent pas ?
    Escal génère beaucoup de bugs.

    Cordialement.

    Gilles.

  • Quoi ou Que dire sinon ça roule chez Free.fr


    SPIP 3.2.0-alpha-1 [23482] + écran de sécurité 1.3.0 + Escal 3.86.44 - stable

Un message, un commentaire ?

Qui êtes-vous ?
Se connecter
Votre message

Ce formulaire accepte les raccourcis SPIP [->url] {{gras}} {italique} <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.