SPIP Blog

Du logiciel libre et de la tendresse

Accueil > Développement > IE6 noyé par un plugin SPIP !

IE6 noyé par un plugin SPIP !

samedi 21 février 2009, par Marcimat

Horripilés par les pertes de cheveux excessives de leurs meilleurs webmestres lorsqu’ils devaient adapter leurs sites pour IE6, les peuplades scandinaves ont décidé de passer à la lutte armée. Ils affichent à tous les utilisateurs de IE6, sur leurs sites, un message agréable et très visible les invitant à mettre à jour cet ancestral navigateur.

La communauté SPIP apprenant cette action a aussitôt décidé de participer à ce mouvement qui prend une ampleur internationale. Les meilleurs experts CSS [1] ont développé un plugin SPIP « pour un meilleur navigateur », qui affiche un magnifique message à tous les détenteurs d’un IE6.

Aussitôt prêt, le plugin « noie » — c’est son nom — est installé sur de nombreux sites SPIP, dont SPIP-Blog, SPIP-Contrib, Programmer SPIP, ce qui donne ce résultat :

JPEG - 108.1 ko
SPIP Contrib, vu par IE6

Passez aussi à l’action !

Le plugin « noie » pour SPIP 1.9 ou supérieur est téléchargeable ici :
http://files.spip.org/spip-zone/noie.zip

Vous pouvez même ensuite compléter un Wiki qui liste des sites proposant cette invitation à mettre son navigateur à jour :
list of websites telling their visitors not to use IE6 : France

Messages

  • Internet Explorer 7 et Internet Explorer 8 sont aussi obsolètes. Faut passer direct à Firefox, Opera, etc et à Linux aussi ;-). L’informatique interne des entreprises n’est constituée que d’agents économiques de micro$oft à leur insu. Il y a un syndrome pour çà, c’est celui de la victime qui à force de vivre avec son bourreau fini par avoir de l’empathie à son encontre.

  • @balluche : tu es bien mignon.
    As-tu déjà entendu parler de compatibilité avec les applis existantes ?
    Es-tu au courant que dans un tout un tas d’entreprises, c’est pas la « direction » informatique qui dicte ses choix en matière de logiciels ?

  • @anonyme : est-ce une raison pour laisser tout ces pauvres gens dans l’ignorance ? Afficher un message informatif est plutôt bienveillant, non ? Et cela n’empêche aucunement les webmestres férus d’accessibilité et/ou d’antiquités de produire un site qui « passe encore sous IE6 » ;-)

  • globalement ie c’est de la grosse m***e. C’est fatiguant de développer pour ie, un pseudo « navigateur » obsolète qui ne devrait même pas exister.

    L’offre de navigateurs dignent de ce nom est légion aujourd’hui.

    Ce message devrait s’appliquer à toutes les versions de ie, sans exception !

  • @l’autre anonyme :
    Sans défendre la politique de µ$, qui n’est que de faire du pognon, le fameux IE est tout de meme la porte principale d’accès à internet. Et combien n’auraient jamais connu FF sans IE ?

    Il y a 2 façons de consommer :
    - Se détourner d’un fournisseur quand les produits ne plaisent plus
    - Informer le fournisseur que ses produits ne conviennent plus et entamer un dialogue constructif.

    Je crois que le plugin proposé entame cette conversation.

    Je vais d’ailleurs l’installer de suite sur certains des sites que j’administre.

    Bien cordialement

Un message, un commentaire ?

Qui êtes-vous ?
Se connecter
Votre message

Ce formulaire accepte les raccourcis SPIP [->url] {{gras}} {italique} <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.