SPIP Blog

Du logiciel libre et de la tendresse

Accueil > Développement > SPIP 3 béta 2

SPIP 3 béta 2

mercredi 4 janvier 2012, par Marcimat

Une nouvelle version beta de SPIP 3 vient de sortir. C’est la seconde à ce jour.
Pour ceux qui le souhaitent [1], vous pouvez tester cette nouvelle version en téléchargeant et en installant SPIP 3 beta 2 avec le zip présent sur files.spip.org

Cette version Beta 2 corrige bien évidemment de nombreuses anomalies et intègre maintenant dans les extensions le plugin SVP, pour « Serveur de Plugins », qui modifie l’interface d’administration des plugins et permet de gérer ainsi la recherche, le téléchargement et les dépendances de plugins.

Entre les deux versions Beta, de nombreux plugins ont été portés vers SPIP 3. Il y a référencés actuellement sur plugins.spip.org près de 200 paquets compatibles SPIP 3.

Nous vous invitons donc à tester, et à faire vos retours. Vous pouvez comme à l’habitude épingler des anomalies sur core.spip.org

Bons tests !


[1Attention : ce n’est pas la version SPIP 3 définitive, mais une version « beta ». Il est donc possible qu’elle comporte encore des bugs, et nous vous déconseillons de l’employer sur un site en production

Messages

  • Et aussi : SPIP 3 nécessite PHP 5.1 minimum, qu’on se le dise :)

  • Ah ? PHP 5.1 ?
    Ça ne va pas faire que des heureux… Même si PHP 5 est souvent installé chez les hébergeurs mutualisés. :-)

  • Merci à tous les développeurs qui font vivre et évoluer SPIP !!

    Je l’utilise depuis de nombreuses années, il ne m’a jamais déçu.
    Plus encore, les concurrents que j’ai récemment testé ne m’ont pas convaincu, et je suis rapidement revenu à notre CMS préféré.

    J’accueille donc avec plaisir cette nouvelle version béta, vivement le lancement officiel ! ^^

  • même pas peur installé en mutualisation de prod & ou qui sont les Bugs ;)

  • longue vie a spip, de tres loin le precurseur du vrai language facile de programmation de squelletes !

    la concurrence...quelle concurrence ? ;)

    Seul chose a changer pour la 4.0 -> passez tout le system en langue anglaise. je sais c’est dommage de laisser tomber le francais mais si on veut que spip soit plus accessible il faut aussi penser au probleme de langue.

  • @philoo : justement, des tas de gens dans le monde ne parlent pas anglais. Quand j’ai commencé SPIP, ce qui m’a séduit c’est justement qu’il soit en Français.

    En plus l’anglais est une très mauvaise langue de communication internationale.

    Voir la série des 10 vidéos sur le sujet https://www.youtube.com/watch?v=taLXSe4c498

  • Justement philoo. Beaucoup de gens ne parlent pas anglais. Non seulement dans le monde, mais aussi en France.

    Quand j’ai commencé à faire du SPIP, je ne parlais pas un mot d’anglais. Si le language avait été en anglais, cela m’aurait rebuté.

    L’anglais, c’est une langue d’élite … et un très mauvais choix en terme de communication internationale.

    Voir https://www.youtube.com/watch?v=taLXSe4c498

    et aussi

    http://www.spip-blog.net/Speak-english-please.html

  • C’est vrai que le monde informaticien étant très anglophone, pips(?) ipps (?) serait plus vendable auprès de la gente informatique.

    Dans quel but ? Plus de spipistes dans le monde ? Faire un pied de nez aux autres cms ?

    A quoi bon ?

    Je pense que spip souffre surtout de :
    C’est français ? C’est de la merde !
    C’est gratuit ? Ça plante !
    Et ce n’est pas que chez les anglophones qu’on retrouve ça.

    Bonne journée,
    Y

  • Bonjour,

    Je suis en train de tester Spip 3.0 en local, franchement bien, mais je ne trouve pas le plugins

    Spip_Bonux 1.8.7 ? Merci pour les réponses.

    Cordialement. Gilles.

    http://cgsebdeb.fr/

  • spip bonux n’est en général plus nécéssaire avec SPIp 3, vu que celui-ci intégre ses fonctions.

  • Oui d’accord mais quand je veut activer Zen Garden il me demande « Spip_Bonux 1.8.7 » ?

  • a alors z garden n’est pas encore prévu pour SPIP 3, ou alors il l’est, mais on lui a pas dit que bonux n’était pas nécéssaire.

    Je regarde et te dis quoi :)

  • @caff2 : oki, alors il existe une version zengarden pour SPIP 3 récupérable sur http://plugins.spip.net/zengarden.html

  • oki, alors effectivement, cette version, bien que marqué compatibel SPIP 3 nécéssite en fait bonux .…et ne marche pas sous SPIP 3.

    Il existe une version en cours de dev pour SPIp 3. C’est une version de dev et je ne suis pas l’auteur, donc je ne me permet pas de dire de générer un zip.

    En revanche :
    - soit tu la récupère par SVN
    - soit tu m’écrit un gentils mot par mail et je t’envoie le zip...

  • @Maïeul, merci pour tous ces renseignements, ton adresse mail stp.

  • @caff2 : contact moi via le un formulaire de contatc, par ex http://www.maieul.net/spip.php?page=contact

  • Merci de cette nouvelle version du Spip ! Je viens de l’installer en local pour la tester et m’actualiser un peu sur Spip (j’étais restée à la version 1.9 de Spip et beaucoup des choses ont changé)

    Pour commencer à bidouiller j’ai une question toute bête pour commencer :

    Avant, pour personnaliser les squelettes je créais un dossier squelettes où j’ai copiais les fichiers de la dist dont j’avais besoin de modifier y compris le fichier habillage.
    Avec Spip 3, si j’ai besoin de changer quelques fichiers, est-ce que je dois créer un dossier squelettes sous le dossier extensions ?
    extensions/squelettes
    Si non, quelle est la marche à suivre pour créer ses propres squelettes ?

    Je vous remercie beaucoup de tout le travail que vous faites, c’est franchement génial. Félicitations à toute l’équipe !

  • Bonjour,

    Apparemment il suffit de faire comme avant : créer un dossier squelettes à la racine du site en non pas dans le dossier extensions.
     ;)
    Désolée pour le derangement

  • Je teste la béta 2 depuis une semaine en localhost
    et je dois dire que je n’ai eu aucun plantage jusque ici.
    Même avec certains plugins en cours de test.
    Bravo aux développeurs !
    Il n’y a plus qu’à attendre la 3.0 finale.
    VITE ! :-))

  • Bonjour,
    Y a-t-il une date de prévue pour la sortie finale ? Ou alors ce sera « quand ce sera prêt » ? (Amitiés aux debianneux...)

  • Bonjour,

    Je teste Spip 3 beta en local (avec Mac et Mamp)
    Je n’ai ajouté aucun plugin ni créé de dossier plugin ni auto à l’intérieur. Dès que j’actionne « gestion des plugis » en espace privé, l’écran est occupé par un message : "1 erreur dans le squelette erreur SQL 1054 ; ;/extensions/svp/formulaires/inc-admin_plugin.html (boucle _plugins, ligne 2 etc. etc.)

    Merci pour tout commentaire utile.

  • Quelle version as tu de SPIP plus précisément ? (écrit dans le pied de page de l’espace privé).
    Es-tu sous mysql ou sqlite ? Quelle est la version de l’extension SVP ?

    Merci.

  • Merci pour la réponse. Voici mes éléments :

    SPIP 3.0.0-beta [18576]

    mysql

    SVP en date du lundi 2 janvier 2012 13:30

  • Hum, ce n’est pas un numéro de version pour SVP :)
    Cela dit, il faudrait qu’on sorte une nouvelle version de SPIP 3, parce que de nombreux bugs ont été corrigés depuis.

  • Ou c’est intéressant de tester mais effectivement il reste pas mal d’adaptations à faire pour « fluidifier » la migration possible. Sans compter que comme beaucoup d’autres, je me suis cantonné au squelette SarkaSpip. Pas compatible non plus !

    Je ne savais pas où aller chercher « la version de l’extension SVP ».

    Merci pour tout le travail réalisé et bonne finalisation !

  • Sur le canal IRC de SPIP on m’a indiqué une doc compliquée qui s’annonce « pour programmeurs [...] pas pour les promeneurs. » Voici donc mes notes pour un tuto, où j’essaye d’expliquer, le plus simplement possible, comment essayer SPIP3.

    Je ne sais pas pourquoi ce n’est pas mieux indiqué, mais toutes les sources de SPIP sont consultables en ligne :

    http://core.spip.org/projects/spip/repository/

    Les dernières versions de SPIP sont disponibles en zip à cette URL :

    http://files.spip.org/spip/dev/

    Mais pour suivre les évolutions, mieux vaut récupérer les sources via SVN, en lançant cette commande dans un terminal (après s’être placé dans le bon répertoire) :

    svn co svn ://trac.rezo.net/spip/spip

    Ensuite, pour faire fonctionner SPIP sur votre machine, il faut un serveur web local. Voir Utiliser SPIP « en local ». Taper ensuite dans un navigateur :

    http://localhost/spip/spip/

    qui affiche Ce site n’est pas encore configuré. Revenez plus tard.... C’est normal. Ajoutez « /ecrire » dans l’URL pour finaliser l’installation :

    http://localhost/spip/spip/ecrire

    J’ai complètement bloqué sur le second écran d’installation où il faut indiquer le type de base de données, par défaut réglé sur « SQLite 3 » une sorte de MySQL allégé, utilisé sur la plupart des smartphones modernes [1]. Je bloque sur l’écran d’install et ses deux messages m’invitant à « consulter les informations fournies par [mon] hébergeur » (ce message est vraisemblablement mal placé) et faire attention car « plusieurs plugins ne fonctionnent qu’avec MySQL » (mais sans m’en fournir la liste qui m’aiderait à savoir quoi choisir). Ça mérite quelque explication :

    - restez sur SQLite 3, plus simple et facile, pour découvrir SPIP3 et pour créer un petit site
    - revenez en MySQL, qui tient mieux la charge, si vous avez l’intention de construire un site plus costaud ou de migrer depuis SPIP 2

    Il restera possible de passer de l’un à l’autre moyennant quelques manipulations de fichiers (en sauvegardant la base via l’admin de SPIP, en récupérant le fichier produit pour le ré-importer sur une autre instance de SPIP, dans la même version mais dans l’autre format de base de données).

    Tout va bien ensuite, c’est comme d’habitude :)

    [1SQLite est le moteur de base de données le plus distribué au monde [...] très populaire sur les systèmes embarqués, notamment sur la plupart des smartphones modernes : l’iPhone ainsi que les systèmes d’exploitation mobiles Symbian et Android l’utilisent comme base de données embarquée (Wikipédia).

  • Bonjour,
    comment passer de spip 2 à spip 3 en mettant à jour la base de données ?
    cordialement

  • La montée de versions en SPIP

    Constante depuis de nombreuses versions, le chargement d’une nouvelle version de SPIP propose automatiquement la mis-à-niveau de la base de données à la connexion suivante de l’administrateur, la quasi-totalité des squelettes qui constituent le site reste fonctionnelle : les eventuelles difficultés pourront venir de certains plugins encore trop dependants du core, qui pourraient necessiter une mise-à-jour.

    Pour d’autres solutions, voir Contrib

  • Bonjour,

    Je teste spip3, et je viens de trouver un truc étrange.
    J’ai activé dans les prefs les articles post-datés. Hors une rubrique ne contenant que des articles avec une date future, ne s’affiche pas. Il lui faut au moins un article passé.

    Merci

  • @chris
    c’est bien normal. une rubrique n’apparaît que si au moins l’un des articles qu’elle contient (elle-même ou l’une de ses sous-rubriques) est publié.
    dans le cas où elle ne contient que des articles « à paraitre », donc « non publiés », elle ne s’affichera pas (tant que l’un au moins de ces articles n’aura pas franchi sa date de publication)

Un message, un commentaire ?

Qui êtes-vous ?
Se connecter
Votre message

Ce formulaire accepte les raccourcis SPIP [->url] {{gras}} {italique} <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.